Tndeer Logo

Page 1 of 1 1
Topic Options
#1240353 - 03/16/09 11:22 AM Hummingbird Depth Finder Issues 525
imograss
4 Point


Registered: 01/19/06
Posts: 469
Loc: Lyles Tennessee

Offline
I was talking to a fellow TNDEER member over the weekend and has the same issue. I have a Hummingbird 525 series depthfinder. I have it on my 14' flatbottom. It will not read depth unless the boat comes to a complete stop. I bought it so I would now how deep the water is below me while I'm running the river (25hp). I have moved the transducer a couple times with the same result. It is in the lower left corner, flush with the bottom of the boat. I have meved it higher but that sends a roostertail of water up and over flooding the transom. Any ideas?
_________________________
I Play Loud

Top
#1240373 - 03/16/09 11:39 AM Re: Hummingbird Depth Finder Issues 525 [Re: imograss]
Baxter83
Good ol' Boys
12 Point


Registered: 09/03/08
Posts: 7304
Loc: Winchester, TN

Offline
Sounds like it's still catching some cavitation. Lower it a little more into the water slightly below the hull and see if that works. Maybe try moving it from one side to the other if that don't work. I have a 565 and a 525. They work fine for me, but it took some time getting the transducers placed properly. I hope this helps, Good luck.
Top
#1240382 - 03/16/09 11:45 AM Re: Hummingbird Depth Finder Issues 525 [Re: Baxter83]
imograss
4 Point


Registered: 01/19/06
Posts: 469
Loc: Lyles Tennessee

Offline
So your's is set with the bracket flush with the bottom of the boat and the transducer is acutally lower than the hull correct? Mine only came with a stationary bracket, not one thats kicks up if you hit something. Thanks for the tip
_________________________
I Play Loud

Top
#1240390 - 03/16/09 11:52 AM Re: Hummingbird Depth Finder Issues 525 [Re: imograss]
Baxter83
Good ol' Boys
12 Point


Registered: 09/03/08
Posts: 7304
Loc: Winchester, TN

Offline
 Originally Posted By: imograss
So your's is set with the bracket flush with the bottom of the boat and the transducer is acutally lower than the hull correct? Mine only came with a stationary bracket, not one thats kicks up if you hit something. Thanks for the tip


Yes, mine will kick up if it hits something. Sounds like a pickle of a situation you got there.

Maybe just try moving it to a different place on the hull to the left or right (keeping it flush). Other than that IDK. I hope you get it fixed, fishing season is upon us.

Top
Page 1 of 1 1


Moderator:  RUGER, Unicam, CBU93, stretch, Bobby G, Cuttin Caller, Kimber45, Mrs.Unicam, Crappie Luck 
Hop to:
Top Posters
4106460
RUGER
88236
Deer Assassin
65979
BSK
61910
Crappie Luck
51392
spitndrum
Newest Members
kiplrrp, MudIslandMemphis, bcole0305, Browningbelgium7, cw308
13555 Registered Users
Who's Online
102 registered (in the dog house!, skewby, Pintail, donkey5150, missalot, wayne, 12 invisible) and 164 anonymous users online.
Forum Stats
13555 Members
42 Forums
99483 Topics
1170288 Posts

Max Online: 788 @ 11/11/13 08:06 PM
Moon Phase
CURRENT MOON
November
Su M Tu W Th F Sa
1
2 3 4 5 6 7 8
9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 29
30
Forum Donations
The TnDeer.Com Deer Talk Forum is for Tennessee Deer Hunters by Tennessee Deer Hunters. If you enjoy using our Talk Forum and would like to contribute to help in it's up-keep. Just submit your contribution by clicking on the DONATE button below and paying with PayPal or a major credit card. Any amount is much appreciated. Thanks for your support!

TN Burn Safe

Generated in 0.041 seconds in which 0 seconds were spent on a total of 14 queries. Zlib compression enabled.